import re
regex = re.compile((r"\n"
r"^((http|https):\/\/)?(www[0-9]\.)?(([A-Za-z0-9_-])+\.{1})+([A-Za-z]{2,4}|\<[^<>]+\>)(\/([A-Za-z0-9_-])+)*(\/)?$"), flags=re.MULTILINE)
test_str = ("https://www.google.com\n"
"http://www.google.net/hello\n"
"https://www.google.<var>\n"
"http://www.google.<hello>/hello\n"
"http://www.google.>hello</hello\n"
"http://www.google.<<hello>/hello\n"
"http://www.google.<<hello>>/hello\n"
"http://www.google.<hello>>/hello")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")