re = /(\([^)]+\))/
str = '.com registration (domain.com)
xl hosting (domain.com)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end