$re = '/\[(.+)\]/';
$str = 'текст [id123456|Пользователь] текст текст текст [id1234556|пользователь] текст текст';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);