re = /\['([^']*)', (\(\) => <[^<>]*>)\],/m
str = 'export default [
[\'AcknowledgementsSection\', () => <AcknowledgementsSection />],
[\'AuthorizedUserSection\', () => <AuthorizedUserSectionWithStore />],
[\'AuthorizedUserAlert\', () => <AuthorizedUserAlert />],
];'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end