package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-z0-9;.-]+)(.*)$`)
var str = `!@#$abc-123-4;5.def)(*&^;\n
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}