$re = '/( *(((([a-zA-Z]+)|([.#](\w|\w+-+\w*)+)|(:(\w+(-\w+)+)(\([a-zA-Z0-9]+\))?)|(:{2}(\w+(-\w+)+))|(\*))(\[ *\w+ *(([\^$|~*]?= *)?((\w|\w+-+\w*)+|((\\\\\') *.+ *(\\\\\'))|((\\\\") *.+ *(\\\\"))|((\') *.+ *(\'))|((") *.+ *("))))?( *\]))*)|(\[ *\w+ *(([\^$|~*]?= *)?((\w|\w+-+\w*)+|((\\\\\') *.+ *(\\\\\'))|((\\\\") *.+ *(\\\\"))|((\') *.+ *(\'))|((") *.+ *("))))?( *\]))+)((([a-zA-Z]+)|([.#](\w|\w+-+\w*)+)|(:(\w+(-\w+)+)(\([a-zA-Z0-9]+\))?)|(:{2}(\w+(-\w+)+))|(\*))*(( +|( *[,~>+] *))(((([a-zA-Z]+)|([.#](\w|\w+-+\w*)+)|(:(\w+(-\w+)+)(\([a-zA-Z0-9]+\))?)|(:{2}(\w+(-\w+)+))|(\*))(\[ *\w+ *(([\^$|~*]?= *)?((\w|\w+-+\w*)+|((\\\\\') *.+ *(\\\\\'))|((\\\\") *.+ *(\\\\"))|(\' *.+ *\')|((") *.+ *("))))?( *\]))*)|(\[ *\w+ *(([\^$|~*]?= *)?((\w|\w+-+\w*)+|((\\\\\') *.+ *(\\\\\'))|((\\\\") *.+ *(\\\\"))|((\') *.+ *(\'))|((") *.+ *("))))?( *\]))+))*)* *(?!.))/y';
$str = ':pseudo-class(value)[attribute~=value]#id.class > ::pseudo-element, element';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;