using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(abc|bcd|cde|def|efg|fgh|ghi|hij|ijk|jkl|klm|lmn|mno|nop|opq|pqr|qrs|rst|stu|tuv|uvw|vwx|wxy|xyz)(1[5-9]\d{2}|20[01]\d|2020)10{1,3}\d";
string input = @"abc1500100
mno16001001
xyz180010000
opq2001101
abd1888101
abc1499101
abc2021101
abc2020201";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}