using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((a{1,4}|a?b|ba){1,3}|(a{1,3}|b){1,4}|((a{2,3}|b){2}|aaba|abaa){2})$";
string input = @"Allowed:
aaaaaaaaaaaa
aaaaaaaaaaa
abaaaaab
baaaaaba
abaaaaba
bbbb
bababa
ababab
aabaabaa
abaabaaa
baaaaaab
baaaaab
baaaaaaaaa
abaaaaaaaa
aabaaaaaaa
aaabaaaaaa
aaaabaaaaa
aaaaabaaaa
aaaaaabaaa
aaaaaaabaa
aaaaaaaaba
aaaaaaaaab
baaaaaba
abaaaaab
babaaaaa
ababaaaa
aababaaa
aaaababa
aaaaabab
baaaabaa
abaaaaba
aabaaaab
baabaaaa
abaabaaa
aabaabaa
aaabaaba
baaaaba
abaaaab
babaaaa
ababaaa
aababaa
aaababa
abba
abbb
bababa
bbaab
abbab
abaabb
baaabaa
abaaaba
aabaaab
baabaaa
abaabaa
abaabaa
aabaaba
Disallowed:
aaaaaaaaaaaaa
aabaabaaa
aababab
bbbba
bbabb
baaaaaaab";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}