$re = '/(\b999\d),/';
$str = '1111, 9993, 9994, 99950, 9909';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);