$re = '/(?<![\w\d])цена(?![\w\d])/u';
$str = 'сценарий
цена';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);