package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:[A-Z]+\. ?)+$`)
var str = `Ing
Ing.
.Ing.
Xx Yy.
XX. YY.
XX.YY.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}