re = /^[0-9]{2,}\\[0-9]{2}\-(?(?=5[15]00)[0-9]{4}\-[0-9]{3}\-|[0-9]{4}\-[0-9]{3}\-[0-9]{2})$/
str = '01\\01-5500-000-'
# Print the match result
str.match(re) do |match|
puts match.to_s
end