#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/export\/var\/path\/(.+?)\..*log"
Local $sString = "/export/var/path/host1.log" & @CRLF & _
"/export/var/path/host-02.ac.lp.our.domain.log" & @CRLF & _
"/export/var/path/host3.ac.lp.our.domain.log"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")