$re = '/(\w[^\d]+)\d+\-\d+/';
$str = 'MM800-30599
900-30509';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);