re = /<([A-Z][A-Z0-9]*)\b[^>]*>(?:(?!\/?\1)[\s\S])*<\/\1>/i
str = '<tag>gimme cookies<tag>gimme more cookies</tag></tag>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end