re = /^(?:(?:(?=.{0,3}(B)))?....)(?:(?:(?=.{0,3}(B)))?....)(?:(?:(?=.{0,3}(B)))?....)$/m
str = 'AAAABBBBAAAA
ABAABBBBAAAA
AAAABBBBABAA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end