$re = '/^<div>[^<>]+<\/div>$/m';
$str = '<div><span>Элемент</span>Текст</div>
<div>Просто текст</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);