package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^.]*[A-Za-z]+[^.]*$`)
var str = `df45543`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}