re = /^([0][1-9]|[12][0-9]|3[01])(\/|-)([0][1-9]|[1][0-2])\2(\d{4})/
str = '27/05/2017'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end