re = /^([0-2][0-9]|3[0-1])(\/|-)(0[1-9]|1[0-2])\2(\d{4})(\s)([0-1][0-9]|2[0-3])(:)([0-5][0-9])(:)([0-5][0-9])$/
str = '28/05/2017 00:06:00'
# Print the match result
str.match(re) do |match|
puts match.to_s
end