$re = '/(?:([A-Za-z]+)\.([A-Za-z]+)|([A-Za-z]+)\.([A-Za-z]+)\.([A-Za-z]+))\.\d+@[^\s@]+/m';
$str = 'firstname.lastname.1234@email.com
firstname.middlename.lastname.1234@email.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);