#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)((ยี่|สาม|สี่|ห้า|หก|เจ็ด|แปด|เก้า)?(สิบ)(เอ็ด|สอง|สาม|สี่|ห้า|หก|เจ็ด|แปด|เก้า)?)สตางค์|(หนึ่ง|สอง|สาม|สี่|ห้า|หก|เจ็ด|แปด|เก้า|สิบ)สตางค์|(ถ้วน)"
Local $sString = "ถ้วน" & @CRLF & _
"หนึ่งสตางค์ " & @CRLF & _
"เอ็ดสตางค์" & @CRLF & _
"สองสตางค์" & @CRLF & _
"สามสตางค์" & @CRLF & _
"สี่สตางค์" & @CRLF & _
"ห้าสตางค์" & @CRLF & _
"หกสตางค์" & @CRLF & _
"เจ็ดสตางค์" & @CRLF & _
"แปดสตางค์" & @CRLF & _
"เก้าสตางค์" & @CRLF & _
"สิบสตางค์" & @CRLF & _
"สิบเอ็ดสตางค์" & @CRLF & _
"สิบสองสตางค์" & @CRLF & _
"สิบสามสตางค์" & @CRLF & _
"สิบสี่สตางค์" & @CRLF & _
"ห้าห้าสตางค์" & @CRLF & _
"สิบห้าสตางค์" & @CRLF & _
"สิบหกสตางค์" & @CRLF & _
"สิบเจ็ดสตางค์" & @CRLF & _
"สิบแปดสตางค์" & @CRLF & _
"สิบเก้าสตางค์" & @CRLF & _
"ยี่สิบสตางค์" & @CRLF & _
"ยี่สิบเอ็ดสตางค์" & @CRLF & _
"ยี่สิบสองสตางค์" & @CRLF & _
"ยี่สิบสามสตางค์" & @CRLF & _
"ยี่สิบสี่สตางค์" & @CRLF & _
"ยี่สิบห้าสตางค์" & @CRLF & _
"ยี่สิบหกสตางค์" & @CRLF & _
"ยี่สิบเจ็ดสตางค์" & @CRLF & _
"ยี่สิบแปดสตางค์" & @CRLF & _
"ยี่สิบเก้าสตางค์" & @CRLF & _
"สามสิบสตางค์" & @CRLF & _
"สามสิบเอ็ดสตางค์" & @CRLF & _
"สามสิบสองสตางค์" & @CRLF & _
"สามสิบสามสตางค์" & @CRLF & _
"สามสิบสี่สตางค์" & @CRLF & _
"สามสิบห้าสตางค์" & @CRLF & _
"สามสิบหกสตางค์" & @CRLF & _
"สามสิบเจ็ดสตางค์" & @CRLF & _
"สามสิบแปดสตางค์" & @CRLF & _
"สามสิบเก้าสตางค์" & @CRLF & _
"สี่สิบสตางค์" & @CRLF & _
"สี่สิบเอ็ดสตางค์" & @CRLF & _
"สี่สิบสองสตางค์" & @CRLF & _
"สี่สิบสามสตางค์" & @CRLF & _
"สี่สิบสี่สตางค์" & @CRLF & _
"สี่สิบห้าสตางค์" & @CRLF & _
"สี่สิบหกสตางค์" & @CRLF & _
"สี่สิบเจ็ดสตางค์" & @CRLF & _
"สี่สิบแปดสตางค์" & @CRLF & _
"สี่สิบเก้าสตางค์" & @CRLF & _
"ห้าสิบสตางค์" & @CRLF & _
"ห้าสิบเอ็ดสตางค์" & @CRLF & _
"ห้าสิบสองสตางค์" & @CRLF & _
"ห้าสิบสามสตางค์" & @CRLF & _
"ห้าสิบสี่สตางค์" & @CRLF & _
"ห้าสิบห้าสตางค์" & @CRLF & _
"ห้าสิบหกสตางค์" & @CRLF & _
"ห้าสิบเจ็ดสตางค์" & @CRLF & _
"ห้าสิบแปดสตางค์" & @CRLF & _
"ห้าสิบเก้าสตางค์" & @CRLF & _
"หกสิบสตางค์" & @CRLF & _
"หกสิบเอ็ดสตางค์" & @CRLF & _
"หกสิบสองสตางค์" & @CRLF & _
"หกสิบสามสตางค์" & @CRLF & _
"หกสิบสี่สตางค์" & @CRLF & _
"หกสิบห้าสตางค์" & @CRLF & _
"หกสิบหกสตางค์" & @CRLF & _
"หกสิบเจ็ดสตางค์" & @CRLF & _
"หกสิบแปดสตางค์" & @CRLF & _
"หกสิบเก้าสตางค์" & @CRLF & _
"เจ็ดสิบสตางค์" & @CRLF & _
"เจ็ดสิบเอ็ดสตางค์" & @CRLF & _
"เจ็ดสิบสองสตางค์" & @CRLF & _
"เจ็ดสิบสามสตางค์" & @CRLF & _
"เจ็ดสิบสี่สตางค์" & @CRLF & _
"เจ็ดสิบห้าสตางค์" & @CRLF & _
"เจ็ดสิบหกสตางค์" & @CRLF & _
"เจ็ดสิบเจ็ดสตางค์" & @CRLF & _
"เจ็ดสิบแปดสตางค์" & @CRLF & _
"เจ็ดสิบเก้าสตางค์" & @CRLF & _
"แปดสิบสตางค์" & @CRLF & _
"แปดสิบเอ็ดสตางค์" & @CRLF & _
"แปดสิบสองสตางค์" & @CRLF & _
"แปดสิบสามสตางค์" & @CRLF & _
"แปดสิบสี่สตางค์" & @CRLF & _
"แปดสิบห้าสตางค์" & @CRLF & _
"แปดสิบหกสตางค์" & @CRLF & _
"แปดสิบเจ็ดสตางค์" & @CRLF & _
"แปดสิบแปดสตางค์" & @CRLF & _
"แปดสิบเก้าสตางค์" & @CRLF & _
"เก้าสิบสตางค์" & @CRLF & _
"เก้าสิบเอ็ดสตางค์" & @CRLF & _
"เก้าสิบสองสตางค์" & @CRLF & _
"เก้าสิบสามสตางค์" & @CRLF & _
"เก้าสิบสี่สตางค์" & @CRLF & _
"เก้าสิบห้าสตางค์" & @CRLF & _
"เก้าสิบหกสตางค์" & @CRLF & _
"เก้าสิบเจ็ดสตางค์" & @CRLF & _
"เก้าสิบแปดสตางค์" & @CRLF & _
"เก้าสิบเก้าสตางค์"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")