re = /^((?:\(?\d{3}\)?[- .]?\d{4}|\(?\d{4}\)?[- .]?\d{3}|\(?\d{5}\)?[- .]?\d{2})[- .]?\d{4})$/
str = '(111)11111111'
# Print the match result
str.match(re) do |match|
puts match.to_s
end