import re
regex = re.compile(r"^(?:\w-\w{4}|\w{2}-\w{3})$", flags=re.MULTILINE)
test_str = ("A-AAAA\n"
"BB-BBB\n"
"CC-CCCC\n"
"DDD-DDDD")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")