$re = '/^.+js\/folder(\/|.*?)[^\/]+?\.js$/m';
$str = 'D:/path/to/project/js/folder/LVL1/LVL2/mylibrary.js
D:/path/to/project/js/folder/mylibrary.js
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);