$re = '/(A(?:(?!A).)*?X(?:(?!B).)*?B)/m';
$str = 'AYB A X Z B AZB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);