re = /^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[!@#$%^&*_=+-]).{8,12}$/m
str = 'aaaaaaaaa
1111aaaaa
12aqQ@dd
12aqQ@ddffasdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end