use strict;
my $str = 's030 12345-67 dsd
(030) 12345 55 99testword
testword (030) 12345 44
0351 4640-123
09623 12 3 33
09234 1233
+49 123 1 2 12 31
0049 2123 1231
+1 3519 1231
0 30 / 12 34 56
0 30 / 12 34 56
030 / 12 34 56
0123 / 12312 123
testword 0178 1232231
+490 178 1232231
testword +36 (351)4740-991 testword
testword +36(351) 4740-991 testword
09623 12333 testword
should NOT match (with the reason why it shouldn\'t match):
+49123123123 //because there is no white space
01781232231 //because there is no white space
123456 //because it doesn\'t have at least 9 digits and no white space
123.123 //because it has a dot
12-12-12 //because there is no white space and there is more than one dash
12-12 -12-12-12 //because there is more than one dash
1990 - 2000 //because it doesn\'t have at least 9 digits
1990-2000 //because it doesn\'t have at least 9 digits and no white space
1990-91 //because it doesn\'t have at least 9 digits and no white space
123 //because it doesn\'t have at least 9 digits and no white space
+36 (351) 47(40-991 //because it has more than one left bracket
+36 (33) 3)4444
)40-991 //because it has more than one right bracket
+23+234 +2346 // because it has more than one plus sign
234 234 234 234 234 // because it has more than one white space in a row
123 123123 // because it has more than one white space in a row
01712123123
01234';
my $regex = qr/(?!\s)(\+?[0-9 .\/()-]{8,}\d)\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}