$re = '/(\'(?:[^\']|(?!<\\\\\\\\)\')*\'|\S+)/m';
$str = 'Some message I want to split \'but keeping this a\\\\\'s a single string\' Voila!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);