import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(?=.)(?:(?:[+-]?\\d*(?:xp|yp|p|z)*)+)[<>]=(?=.)(?:(?:[+-]?\\d*(?:xp|yp|p|z)*)+)$)";
final String string = "xp+yp+6p<=z+1\n\n"
+ "xp+2yp+3p+4<=5z+6\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}