$re = '/((?:[A-Z][a-z]+\s?){2})/m';
$str = 'One FishTwo FishRed FishBlue Fish';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);