$re = '/^(a(?:(?1)|b)c)$|^(b)$/m';
$str = 'b
abc
aabcc
aaabccc
But does NOT match any of:
ab
bc
aabc
abcc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);