import re
regex = re.compile(r",(?![^()]*\))", flags=re.MULTILINE)
test_str = "life, would, (last , if ), all"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)