import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Node.*?label=\"\\{(.*\\bORD\\b.*)\\}\".*?;";
final String string = "Node0x7fd34984d728:s1 -> Node0x7fd34984d600:d0;\n"
+ "Node0x7fd34984d850 [shape=record,shape=Mrecord,label=\"{Register %vreg13|0x7fd34984d850|{<d0>i32}}\"];\n"
+ "Node0x7fd34984d978 [shape=record,shape=Mrecord,label=\"{{<s0>0|<s1>1}|CopyFromReg [ORD=1]|0x7fd34984d978|{<d0>i32|<d1>ch}}\"];\n"
+ "Node0x7fd34984d978:s0 -> Node0x7fd3486095f0:d0[color=blue,style=dashed];\n"
+ "Node0x7fd34984d978:s1 -> Node0x7fd34984d850:d0;\n"
+ "Node0x7fd34984daa0 [shape=record,shape=Mrecord,label=\"{Register %vreg14|0x7fd34984daa0|{<d0>i32}}\"];";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}