package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*\bword\b.*$|(.+)`)
var str = `string has word
string does not have it
another string`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}