$re = '/([^ ,]+)(?:,|$)/m';
$str = 'ps_args: com26:57600, 19-1125063, 1234, abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);