$re = '/^\b(?:[A-Z]\w+\b(?:\s*)?)+$/m';
$str = 'Naveen Kumar
Naveen kumar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);