// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(https?:\/\/([0-9a-z]+(?:[\-\.][0-9a-z]+)+)(\/(?:\/\w+\/)*\w*)?(\?\w+\=[^\s\&\=]+(?:\&\w+\=[^\s\&\=]+)*)?(\#\S+)?)\b").unwrap();
let string = "<a href=\"https://worldofwarships.ru/\">https://worldofwarships.ru/</a><div><br></div>
<div data-test=\"https://worldofwarships.ru/1\">https://worldofwarships.ru/1</div>
<div>https://worldofwarships.ru/0</div>
<div>https://worldofwarships.ru/0</div>
<div> https://worldofwarships.ru/2</div>
https://worldofwarships.ru/3?test=https://worldofwarships.ru/
https://worldofwarships.ru/4#https://worldofwarships.ru/
https://worldofwarships.ru/5
<div>https://worldofwarships.ru/3<br clear=\"all\">
<div><br></div>-- <br><div class=\"gmail_signature\"><div dir=\"ltr\">Тестовый аккаунт</div></div>
</div>
<img src=\"https://worldofwarships.ru/3?test=https://worldofwarships.ru/3\"/>
<img src=\"https://worldofwarships.ru/3#https://worldofwarships.ru/3\"/>
<form action=\"https://worldofwarships.ru/3\"></form>";
let substitution = "<a href=\"$1\">$1</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}