$re = '/(?:([\w]+)\.)?(?:([\w\\\\]+)\:\:)?([\w]+)/m';
$str = 'p3id.\\namespace\\path\\la_clas1sE::met3hod
class::method
fx
pid.fx
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);