$re = '/<(a+) (?!(?:href=(["|\']+)([http:\/\/])*link\.com([\/])?(.*?)["|\'])) *[^>]*>(.*?)[^>]>/m';
$str = '<a href="google.ru">test</a>
<a href="http://link.com"></a>
<a href=\'sterium.com\'></a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);