import re
regex = re.compile(r"^(?:0|\s?)[1-79](?:[\.\-\s]?\d\d){4}$")
test_str = ("05-59-84-14-18\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")