$re = '/<[^>]*?(?:(?:(\'|")[^\1]*?\1)[^>]*?)*>/';
$str = 'some text <tag link="fo>o"> other text
some text <tag link="fo>o"> other text
<meta name="keywords" content="javascript,regex><><><<>,regular expression,debugger,explainer,helper,tester,match,pcre,python,editor" />
<meta name="descrip><>><>tion" content="Online reg>---<ex tester, debugger with highlighting for PHP, PCRE, Python and JavaScript." />
<meta name="author" content="Firas Dib" />
content content content
content <meta property="twitter:ca><<>>><>><>rd" content="summary" />content content
content content
content content content <meta property="twitter:site" content="@regex101" />content content content content
content content content content
<meta property="twitter:title" content="Regex101 - online regex editor and debugger" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);