re = /\[([^\.]*)\.?([^\.\]]*)\]/
str = '1234 [124dsqdab-cqqc.VALUE]
[VALUE]
[VALUE] hdsqqq'
# Print the match result
str.match(re) do |match|
puts match.to_s
end