package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"((?:\\['"]|[^"])+)"`)
var str = `.js("aaa").js("b\"bb").js("ccc")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}