$re = '/,(?=[^\(]*\))/';
$str = '123 (abc,def) 567';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;