#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ixsmu)# Start defining" & @CRLF & _
"(?(DEFINE)" & @CRLF & _
" (?<XSEP>\s*[xх\*\-\s]?\s*)" & @CRLF & _
" (?<MARGIN>(?:\.\d)?)" & @CRLF & _
" (?<RADIUS>r?[12]\d(?&MARGIN))" & @CRLF & _
" (?<J>(?:1[01]|[4-9])(?&MARGIN)j?)" & @CRLF & _
" (?<DIAM>" & @CRLF & _
" \b" & @CRLF & _
" (?:" & @CRLF & _
" (?&RADIUS)(?:\s*\/\s*(?&J))?" & @CRLF & _
" |" & @CRLF & _
" (?&J)(?&XSEP)(?&RADIUS)" & @CRLF & _
" )" & @CRLF & _
" \b" & @CRLF & _
" )" & @CRLF & _
" (?<PCD>\b(?:[pb]cd\s*)?[34568](?&XSEP)(?:98|[12]\d{2})(?&MARGIN)\b)" & @CRLF & _
" (?<ET>(?:(?:et|ет)\s*)?\-?\d+(?&MARGIN)\b)" & @CRLF & _
" (?<CB>\b(?:(?:цо|cb|d(?:ia)?)\s*)?\d{2,3}(?&MARGIN)\b)" & @CRLF & _
")" & @CRLF & _
"# End defining" & @CRLF & _
"(?:" & @CRLF & _
"(?<diam>(?&DIAM))" & @CRLF & _
"|" & @CRLF & _
"(?<pcd>(?&PCD))" & @CRLF & _
"|" & @CRLF & _
"(?<et>(?&ET))" & @CRLF & _
"|" & @CRLF & _
"(?<cb>(?&CB))" & @CRLF & _
")"
Local $sString = "r22 pcd 4x108 ET 45.5 ЦО 58.5" & @CRLF & _
"15 /5.0j 6*108 et45 ЦО 58.5" & @CRLF & _
"15/ 5.0j 4x108 -45.5 58.5" & @CRLF & _
"pcd 4x138 15/5.0j ET58.5 ЦО45" & @CRLF & _
"ЦО45.5 ET58.5 19 pcd 4x 108" & @CRLF & _
"" & @CRLF & _
"r15/5.6j pcd 5х112 ET60 CB66" & @CRLF & _
"et50 r15/5 5х112 ET60 d66" & @CRLF & _
"r15/5 pcd 5*112 ET60 dia 66" & @CRLF & _
"" & @CRLF & _
"5.6j x 15.5 pcd 5 х 112 ет -60 CB66" & @CRLF & _
"" & @CRLF & _
"5x15.5 5х112.5 ET60 CB66" & @CRLF & _
"" & @CRLF & _
"250/50 r16"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")