import Foundation
let pattern = #"^[A-Z]{1,3}[0-9]{1,4}\.?([0-9]{1,2})?\ ?\.?[A-Z]{1}[0-9]{1,}.?\ ?([A-Z]{1,2}[1-9]{1,})?\ ?([0-9]{1,})?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
QE714.5 .Z34 1982
PS3619.G73 D56 2013
QE861.5 .P43 1999
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)