re = /\b(?:blue house|red car|red)\b/m
str = 'There is a red car parked in front of a blue house with a fence painted red.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end