using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""[^\""]*\""\s(?<status>\d+)([^\""]*\""){4}\s(?<response_time>[^ ]*)";
string input = @" ""POST /v2/endpoint HTTP/1.0"" 200 91 ""http://example.com/"" ""Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36"" 0.029 ""127.0.0.1"" ""some-id""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}