$re = '/(var\s*mapaOportunidade\s*=\s*\{\}\s*;)((?s).*)(var)/';
$str = 'var mapaOportunidade = {};
mapaOportunidade[113] = \'Promoção Exclusiva p/ você - 06 2016\';
mapaOportunidade[112] = \'101 a 150 maiores CNs - Evento Mães 2016\';
mapaOportunidade[110] = \'50 maiores CNs - Evento Mães 2016\';
mapaOportunidade[111] = \'51 a 100 maiores CNs - Evento Mães 2016\';
mapaOportunidade[8] = \'Reinicio\';
mapaOportunidade[114] = \'Passe pedido e resgate seus 10 pontos, trocando pelos produtos que quiser!\';
mapaOportunidade[90] = \'Ação voltada a ativação de CNs vindas da celula de prospecção e que ainda não colocaram seu 1o pedido\';
mapaOportunidade[115] = \'Ação para estimular o relacionamento e venda com consultores que apresentam grande chance de cessação e estão em status i4 e i5\';
mapaOportunidade[116] = \'Promo Chegou, Levou! - Ciclo 06/2016\';
var mapaTipoOportunidade = {};
function mostraDescricaoOportunidade(combo) {
try {';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);